DebugPress 2.1

Published: · Author: · Category:

DebugPress 2.1 is a minor plugin update, but it still includes some smaller, new features, very important updates, and several bug fixes, and it has been tested with the latest PHP 8.2 and WordPress 6.1.

The new plugin version includes the latest version of the KINT library (5.0.1) with improved support for new PHP features in 8.1 and 8.2; it has many updates to the plugin code, many PHP language syntax changes and tweaks, many bug fixes related to PHP 8.2 and other stuff too.

The query panel is improved, with a showing of the Global Post and Meta Data for that Global Post and changes in the panel layout to accommodate for the inclusion of the Post object display.

The latest version of the plugin, DebugPress 2.1, requires PHP 7.2 or newer (tested with PHP 8.1 and 8.2); it supports WordPress 5.2 and newer, including the latest 6.1. For a list of all changes, check out the full changelog.

Let me know if you find any new issues with the plugin and if you have suggestions for some future features.

Leave a Comment

Grammerly - The World's Best Grammar Checker